Mailing ListMailing List   FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Default speed too high after opening with Import Raw Data

 
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion
View previous topic :: View next topic  
Author Message
huckncatch



Joined: 18 Jan 2016
Posts: 3
Location: PDX

PostPosted: Mon Jan 18, 2016 4:53 am    Post subject: Default speed too high after opening with Import Raw Data Reply with quote

I needed to recover a corrupted AIFF and the resulting audio is all there (I haven't listened to it all yet) but at the nominal playback speed, it's way too fast. I need to back it off to one shy of -24 for it to sound normal. The total time for the sound (as displayed) doesn't make sense either, maybe half of what it should be.

Is this a sample rate issue? How can I save this audio at the correct speed?

Thanks, Jim

BTW, I'm not sure how the file got corrupted. I first modified the AIFF chunks by using 0xED and was able to get AP to open the file and thought I was good to go. But after listening almost 27 min in, the audio started to repeat so I messed up on some size calculation somewhere. Thankfully I finally remembered the Import Raw Data capability but now need to address this speed issue.
Back to top
View user's profile Send private message AIM Address
dinojrx



Joined: 11 Nov 2009
Posts: 78
Location: Berlin / Germany

PostPosted: Mon Jan 18, 2016 11:32 am    Post subject: Default speed too high after opening with Import Raw Data Reply with quote

Hi Jim,

your guess is right: you have to play with sample rate and sample size. In the bottom left corner there you can change both settings. Try 44.100 Hz and 16 Bit. It’s the most common setting. Next I’ll try 48.000 Hz and 24 Bit. Furthermore you have check the box „ Don’t resample“ to make AP interpret the sound again.

Good luck!


Quote:
Am 18.01.2016 um 10:36 schrieb huckncatch <forum2mail@hairersoft.com>:

I needed to recover a corrupted AIFF and the resulting audio is all there (I haven't listened to it all yet) but at the nominal playback speed, it's way too fast. I need to back it off to one shy of -24 for it to sound normal. The total time for the sound (as displayed) doesn't make sense either, maybe half of what it should be.

Is this a sample rate issue? How can I save this audio at the correct speed?

Thanks, Jim

BTW, I'm not sure how the file got corrupted. I first modified the AIFF chunks by using 0xED and was able to get AP to open the file and thought I was good to go. But after listening almost 27 min in, the audio started to repeat so I messed up on some size calculation somewhere. Thankfully I finally remembered the Import Raw Data capability but now need to address this speed issue.




_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list


_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list
Back to top
View user's profile Send private message Visit poster's website
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1615

PostPosted: Mon Jan 18, 2016 2:51 pm    Post subject: Default speed too high after opening with Import Raw Data Reply with quote

When you open the AIFF file in AP, besides the fact that the audio gets weird after 27 minutes, what are the sample rate / size it displays? You should use those settings in the "import raw data" dialog. Regards,

Martin

--
HairerSoft
http://www.hairersoft.com/



_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list
Back to top
View user's profile Send private message Send e-mail Visit poster's website
huckncatch



Joined: 18 Jan 2016
Posts: 3
Location: PDX

PostPosted: Mon Jan 18, 2016 6:33 pm    Post subject: Reply with quote

Thanks for all the info.

It was reading the data correctly at 16 bit/44.1 kHz but my problem turned out to be I didn't set the channel setting to mono (having it pop up in stereo should have been my first clue, but I was focused on the speed issue)

Problem solved! Thanks again!

Jim
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group