Mailing ListMailing List   FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Waves plugins--blank interface

 
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion
View previous topic :: View next topic  
Author Message
tokyofan



Joined: 12 May 2009
Posts: 30
Location: Tokyo

PostPosted: Wed Nov 21, 2018 12:55 am    Post subject: Waves plugins--blank interface Reply with quote

After installing the latest AP (2.5.1), all my Waves plug-ins (v10) have blank (black) interfaces are are unusable.
Please advise!!

Running Mojave on new Mac Mini
Back to top
View user's profile Send private message
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1676

PostPosted: Sat Nov 24, 2018 8:48 am    Post subject: Waves plugins--blank interface Reply with quote

Hi, is that only in dark mode or also in light mode? (You may want to quit and relaunch Amadeus Pro when switching modes to make sure that the plug-in adjusts itself correctly.) Regards,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1676

PostPosted: Sun Nov 25, 2018 3:53 pm    Post subject: Waves plugins--blank interface Reply with quote

OK, let me try to figure out at what point exactly that behaviour changed on your system. Could you please download the three versions at

http://www.hairersoft.com/Downloads/AmadeusPro_2024.zip
http://www.hairersoft.com/Downloads/AmadeusPro_2059.zip
http://www.hairersoft.com/Downloads/AmadeusPro_2061.zip

and let me know which ones work / don't work as far as the Waves plug-in is concerned? Build 2024 is identical to the official release 2.4.7, so that one should work. Build 2059 is the official 2.5.0 release which has no change whatsoever in the way Audio Units are implemented, so I would expect that one to work as well. It does however implement some changes in order to behave correctly in Mojave's "dark mode", maybe some of these affect the Audio Unit dialog... Build 2061 implements a change which in principle should only affect the "generic" views of Audio Units, but since that's the only change I made that has a direct effect on Audio Units, maybe this caused the problem.

(Note: builds 2059 and 2061 have a serious bug in the way Mp3 files are handled, so don't use them to open / save Mp3 files.) Thanks a lot in advance,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1676

PostPosted: Mon Nov 26, 2018 9:11 pm    Post subject: Waves plugins--blank interface Reply with quote

Hi, it appears that this is a bug in the Waves plug-ins that is triggered on Mojave whenever the host application supports dark mode. I was able to reproduce this behaviour on one of my computers, also when using Apple's own reference Audio Unit host instead of Amadeus Pro. The only workaround at the moment is to disable dark mode support in Amadeus Pro. This is done in the version at

http://www.hairersoft.com/Downloads/AmadeusProNoDark.zip

This is of course a rather crude workaround, but it seems to be the only way to get around this until Waves gets fixed. (I have also reported that bug to their developers.) Regards,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1676

PostPosted: Thu Nov 29, 2018 11:39 am    Post subject: Waves plugins--blank interface Reply with quote

After some testing and communication with Waves Audio, it seems that this is due to a bug in the current version (10.14.1) of macOS Mojave. The current public beta version of macOS 10.14.2 appears to have fixed this bug and the interface for the Waves plugins displays correctly in Amadeus Pro on that version of the system. I assume that this fix will be rolled out in the official version 10.14.2 within the next few weeks. Regards,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group