Persistent Installation Dialog Box

Discussion forum for Amadeus users

Moderator: Martin Hairer

Post Reply
Bull
Posts: 41
Joined: Tue Jun 08, 2010 5:49 pm
Location: Blacksburg, Virginia

Persistent Installation Dialog Box

Post by Bull »

When I started AP this morning I was offered the option to upgrade to 1.5.2. I clicked the download and install now. AP quit, started up again with dialog "Amadeus Pro 1.5.2 has been downloaded and is ready to be installed." Clicked Install Now. AP quit and nothing happened. Started manually, got the same Dialog. Clicked the other option (Install when I quit...) and then quit. Nothing happened. Downloaded 1.5.2 and manually installed. OK, now version says 1.5.2 (858). But every time I start AP I get the same dialog. How do I make it go away and stay away?

User avatar
Martin Hairer
Site Admin
Posts: 1832
Joined: Wed Nov 08, 2006 11:49 am
Contact:

Persistent Installation Dialog Box

Post by Martin Hairer »

How do I make it go away and stay away?
The easiest thing is to delete the prefs:

Library/Preferences/com.HairerSoft.AmadeusPro.plist

This will destroy your settings though. The less invasive option is to double-click
that file and to just delete the line that starts with HSInstallNewApplicationLocation.
Regards,

Martin

HairerSoft
http://www.hairersoft.com/


_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list

Charles Slater
Posts: 1
Joined: Mon Jan 08, 2007 6:34 pm
Location: Bowral, NSW, Australia
Contact:

Post by Charles Slater »

Thanks Bull for submitting this query and of course thanks martin for your response.

I was experiencing exactly the same problem myself.
Charles Slater (Australia)

User avatar
ryckeboerg
Posts: 1
Joined: Thu Nov 04, 2010 11:45 am
Location: French Flandrers

Post by ryckeboerg »

Thanks too ! :)

(exactly same problem)
Gege

Stefano Fonzarelli
Posts: 5
Joined: Tue Nov 09, 2010 9:06 am

Post by Stefano Fonzarelli »

Martin, I followed your advice of deleting the plist-item. This rendered me with an unregistered version. So I looked up my registration data and re-entered them. Much to my surprise the annoying pop-up was back. :(

I also discovered through "About Amadeus Pro" in the menu, that it was still 1.5.1 !!! So I had never updated, after choosing "update now". :(

I told Amadeus in the preferences to check for the update again, repeating the whole procedure. The result was still the same, even after logging out of OSX and back in again, and then restarting Amadeus. :(

:idea: So I finally decided to download a copy of Amadeus Pro 1.5.2 manually through your website. Now I am half-way there. My Amadeus Pro has been updated to 1.5.2, but I still get the annoying pop-up telling me the otherwise.


I decided to switch-off automatic updating in preferences altogether. But this should not be the definitive solution, and still I keep geeting the pop-up on startup. :(

User avatar
Martin Hairer
Site Admin
Posts: 1832
Joined: Wed Nov 08, 2006 11:49 am
Contact:

Persistent Installation Dialog Box

Post by Martin Hairer »

[Idea] So I finally decided to download a copy of Amadeus Pro 1.5.2 manually through your website. Now I am half-way there. My Amadeus Pro has been updated to 1.5.2, but I still get the annoying pop-up telling me the otherwise.
Have you tried deleting the plist again? That should work...
I decided to switch-off automatic updating in preferences altogether. But this should not be the definitive solution, and still I keep geeting the pop-up on startup. :(
Version 1.5.2 should behave properly for the next upgrade. The problem was
that Apple changed the default setting of their compiler recently, so that by default
code wouldn't run on G4 machines. The updater program was then compiled with
the wrong settings, thus the crashes... Regards,

Martin

HairerSoft
http://www.hairersoft.com/


_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list

User avatar
Martin Hairer
Site Admin
Posts: 1832
Joined: Wed Nov 08, 2006 11:49 am
Contact:

Persistent Installation Dialog Box

Post by Martin Hairer »

Sorry, I got that slightly wrong. The updater is still compiled with the wrong
settings in 1.5.2, but will be fixed in 1.5.3. So those of you running on a G4
will still have the same problem upgrading to 1.5.3. Regards,

Martin

HairerSoft
http://www.hairersoft.com/


_______________________________________________
Amadeus forum mailing list
Unsubscribe / change settings at http://two.pairlist.net/mailman/listinfo/forum_list

Stefano Fonzarelli
Posts: 5
Joined: Tue Nov 09, 2010 9:06 am

Post by Stefano Fonzarelli »

Thank you for your swift reply and please, do keep G4 versions coming when you put out new releases! :D

I'm very impressed with your software so far. As a pro I am really impressed with it's capabilities. Amadeus Pro concentrates fully on (high quality) audio with the option of VST-plugins, but without being 'big' and 'complicated'.

Post Reply