Mailing ListMailing List   FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Dragging m4a files into Itunes

 
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion
View previous topic :: View next topic  
Author Message
BobD



Joined: 11 Jan 2009
Posts: 2

PostPosted: Sun Jan 11, 2009 12:39 am    Post subject: Dragging m4a files into Itunes Reply with quote

When I drag m4a files created with Amadeus Pro into my Itunes Library everything seems fine until I play one of the songs. It plays fine but after 1 play the Name of the Song has the track number added in front of the song name. The m4a files were created from LP after editing markers and cleaning up cracks and then by "Split According To Markers. (bit rate 320, m4a, AAC compression)
This happens consistently and is correctable through Itunes Get Info editing.

Suggestions?

Confused
Back to top
View user's profile Send private message
Lou Kash



Joined: 16 Jul 2008
Posts: 87

PostPosted: Mon Jan 12, 2009 10:21 am    Post subject: Reply with quote

From what I can say, there is a bug, probably in the QuickTime framework, where Apple Lossless (which uses also the m4a container) tags created outside iTunes are not editable or not even readable by iTunes. This happens not only to files created/edited by Amadeus, but also with files processed with dedicated tag editors like Media Rage. And thus likely it happens to compressed AAC/m4a files as well.

The workaround so far has been to leave the edited files uncompressed (AIFF) and without tags and do all converting and tag editing later within iTunes.

Quote:
after 1 play the Name of the Song has the track number added in front of the song name.


iTunes 8 and higher automatically adds the track number to the beginning of the file name. Then, when there is no Track Name tag (or when iTunes can't read it), it will show the file name as track name instead.

The automatic track numbering used to be an option in earlier versions of iTunes, but Apple in its "infinite wisdom" has hidden it from us dumb users. So now it's available only as a "hidden preference".
Get Doug Adams' helper application to turn the hidden iTunes prefs on and off:
http://dougscripts.com/itunes/scripts/ss.php?sp=changehiddenprefs

Quote:
is correctable through Itunes Get Info editing.

Sort of. iTunes likely doesn't even write the tag to the file, only to its internal database. If you remove the file from the iTunes library and then reimport, iTunes will possibly show the file name again...
Back to top
View user's profile Send private message Visit poster's website
BobD



Joined: 11 Jan 2009
Posts: 2

PostPosted: Thu Jan 15, 2009 4:16 am    Post subject: Reply with quote

Lou,
Thanks for the tip. I'll give it a try. However I also make a CD versions of the LPs I encode with AP. When I import with AP encoded CDs the problem doesn't happen. So I now have 3 workarounds. Too bad we can only treat the symptoms instead of correcting the problem.

thanks again
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group