Mailing ListMailing List   FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Audio levels - either a newbie problem or a massive bug

 
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion
View previous topic :: View next topic  
Author Message
fourquarts



Joined: 24 Sep 2014
Posts: 5

PostPosted: Wed Sep 24, 2014 8:03 am    Post subject: Audio levels - either a newbie problem or a massive bug Reply with quote

Hi, all - I've been struggling with this problem for about a year, and all this time I thought that the problem was my preamp. It seems, however, that the problem is originating in Amadeus Pro (AP), so far as I can tell. Obviously, it is entirely possible that I'm just not understanding something, but please read about my tests and let me know if you think I'm insane.

My problem has been that my recordings are too quiet, and when I increase the gain on the preamp to get (almost) acceptable peak levels, the background noise is rather horrid. What I basically was able to narrow this down to, as a measurable difference, was that the peaks in AP are lower than they are in other software.

To make a rather long story short, I have devised some tests and found that, with the same preamp and gain settings, I get exactly the sort of sound you would expect when I use other software, but not when I use AP.

Below is the recording test I did to prove this to myself.

To make the test valid, I wanted to eliminate as many variables as possible. To this end, I did the obvious. I recorded all the samples:

- in the same environment (my booth)
- with the same mic, preamp, and gain settings

(I've also tested the mic on a friend's setup, and it sounded great, so I know the mic's ok.)

However, to further protect against variability:

- I recorded myself reading some text on my iPhone. This was to ensure that the audio being produced for the mic in the booth would be the same every time. The sound quality of that recording is terrible, but it was consistent across test recordings, which was my goal.
- The phone was placed on a music stand in front of the mic and was not touched at all during the tests. I set the ringtone to my recorded text and simply called myself from another phone to play the ringtone.
- I created a brand-new user profile so that the settings of each app would be on their defaults (to protect against my having changed a setting and thus having caused the problem myself).
- I recorded all the samples with the same 3 pieces of software (AP, QuickTime Player, and Audacity).
- I did a set of recordings for each piece of software using two different preamps (Onyx Blackjack and Focusrite Scarlett 2i2), to rule out the preamp as the source of the problem.
- When using an external preamp, the gain is no longer alterable from within Amadeus Pro, so that's not a variable either.

I'm using AP 2.1.7 from the website because the MAS version isn't working right now.

I used AP's Waveform Statistics to determine the peak amplitude for each file.

The results are as follows:

Onyx Blackjack:
Code:

- QuickTime Player (max recording quality)                  Peak Amplitude    -7.3 dB
- Audacity (saved as FLAC, highest-quality settings)                          -7.2 dB
- Amadeus Pro (saved as .amad)                                                -13.3 dB


Focusrite Scarlett 2i2:
Code:

- QuickTime Player (max recording quality)                  Peak Amplitude    -4.5 dB
- Audacity (saved as FLAC, highest-quality settings)                          -4.6 dB
- Amadeus Pro (saved as .amad)                                                -10.7 dB


Note that the peaks in the two preamps differ because I wasn't trying to get them to be the same as each other - the point was that, for each preamp individually, the gain levels were not touched between recordings.

Note also that the difference between QT Player and Audacity in both cases is very small (0.1 dB), whereas the difference between those two and Amadeus Pro in both cases is around 6 dB. It may not seem like much in print, but it makes a big difference! The difference in AP's peaks and the others' is seemingly small, but that doesn't give you the full picture in the difference in the sound. The difference when listening to a living person talking into the mic is very significant. Using the peaks here is just a way to quantify the difference (and that a difference is occurring).

So am I crazy? Or is Amadeus Pro doing something to alter the sound as it is recorded? I can upload the audio files for the above tests, but you won't see much beyond the fact that the waveforms are obviously larger for the recordings from other apps. (No, I haven't changed the zoom levels in AP.)

If someone has a solution or can at least confirm that this is a bug, I would greatly appreciate it. Thanks!

PS: I have done similar tests, though admittedly less thorough, with AP versus Tracktion, and the results are the same.

PPS: AP can't read files recorded in QT Player unless the extension is changed to .aiff - FYI.

Edit: Running OS X 10.9.5 on a Mid-'09 MBP


Last edited by fourquarts on Fri Sep 26, 2014 5:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
dinojrx



Joined: 11 Nov 2009
Posts: 78
Location: Berlin / Germany

PostPosted: Wed Sep 24, 2014 5:13 pm    Post subject: Reply with quote

Hi,

just a short question to get assured: Did you choose the right recording interface in AP? You select it in the preferences.

Best
Back to top
View user's profile Send private message Visit poster's website
fourquarts



Joined: 24 Sep 2014
Posts: 5

PostPosted: Wed Sep 24, 2014 5:54 pm    Post subject: Reply with quote

I take it that you mean the input source in the sound tab of the preferences.

Yes. : )
Back to top
View user's profile Send private message
fourquarts



Joined: 24 Sep 2014
Posts: 5

PostPosted: Thu Sep 25, 2014 6:42 pm    Post subject: Reply with quote

Any thoughts?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group