Mailing ListMailing List   FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Preferences corrupted after install of 2.4.2 update

 
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion
View previous topic :: View next topic  
Author Message
RRettke



Joined: 18 Mar 2016
Posts: 7
Location: Wisconsin USA

PostPosted: Wed Oct 04, 2017 3:44 pm    Post subject: Preferences corrupted after install of 2.4.2 update Reply with quote

Hi Martin,

After installing the 2.4.2 update, weird things began happening, especially with the waveform display and editing tools. I have captured a video to show you but before I sent it, I was looking through the forum and found a post where you recommended trashing the preferences file and gave instruction to Neil as to how to do that. I decided to do that also. Doing so appears to have cleaned up the anomalies I was experiencing, but it was a brief test. If I run into any re-appearing I will let you know, but for now it appears that the install of the update somehow corrupted the preferences plist and it seemed to get worse over time. So all is well at this time, but I wanted you to know, since it appears at least 2 of us have had preferences anomalies after installing 2.4.2.
Back to top
View user's profile Send private message
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1612

PostPosted: Wed Oct 04, 2017 4:08 pm    Post subject: Preferences corrupted after install of 2.4.2 update Reply with quote

Hi, do you happen to have a backup copy of the corrupted prefs file by any chance? If I could reproduce this issue, I might be able to provide a fix (or at least prevent it from happening again in the future). Thanks,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
RRettke



Joined: 18 Mar 2016
Posts: 7
Location: Wisconsin USA

PostPosted: Wed Oct 04, 2017 5:14 pm    Post subject: Reply with quote

Yes, I do have a backup of the corrupted preferences (just pulled it from the trash, where I had carefully placed it.)

Whats the best way to get this to you?
Back to top
View user's profile Send private message
RRettke



Joined: 18 Mar 2016
Posts: 7
Location: Wisconsin USA

PostPosted: Wed Oct 04, 2017 6:34 pm    Post subject: Reply with quote

Actually Martin, the problems are re-appearing after creating the new preferences.

Both Display and insertion point issues. I would be happy to document these and take some screen capture videos - but right now I am under the gun to get a bunch of CD's edited and off to our production facility.

I am going to see if I can install the previous version from a backup so I can get this done today. If that goes well, then I re-install 2.4.2 and see if I can't document what is going on, but right now it is keeping me from getting my work done.
Back to top
View user's profile Send private message
RRettke



Joined: 18 Mar 2016
Posts: 7
Location: Wisconsin USA

PostPosted: Thu Oct 05, 2017 2:52 am    Post subject: Reply with quote

It took me a lot of messing around to go bak to 2.3.1. I ended up trashing 2.4.2 and all the associated files and installing from scratch. Even then 2.3.1 seemed weird but eventually I realized that all my prefs had changed and that was causing me consternation. I eventually got them set back to where I wanted and was able to complete my tasks.

I then thought, what the hey, lets try just installing 2.4.2 as designed and see what happens. So I simply re-downloaded 2.4.2 and dropped it in the app folder and so far, things appear to be ok. I am, to say the least baffled. I will continue to run 2.4.2 and see if it degrades to the strangeness I encountered yesterday.

I do have the "corrupted" prefs file, although at this point I am uncertain about it's corruption. I also have a video of the incredible vibrating display I encountered which began this whole fiasco.

Just so you know, I did reboot my iMac before I ever reported any issue, and the problem persisted after the reboot. Now, having totally purged everything associated with Amadeus Pro and reinstalling 2.3.1 and then 2.4.2 things seem ok. I will be doing a bunch more editing next week, perhaps a little before then, but should anything turn up I'll let you know, as of right now, it appears ok.

If you would like the prefs file and the video just let me know how to get them to you.

Thanks
Back to top
View user's profile Send private message
Martin Hairer
Site Admin


Joined: 08 Nov 2006
Posts: 1612

PostPosted: Sun Oct 08, 2017 6:44 pm    Post subject: Preferences corrupted after install of 2.4.2 update Reply with quote

Quote:
If you would like the prefs file and the video just let me know how to get them to you.

That would be great, please send me the prefs file and a link to the video to martin@hairersoft.com. Thanks,

Martin

--
HairerSoft
http://www.hairersoft.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.hairersoft.com Forum Index -> Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group